Wave Website Is Back Up
Incident Report for Wave
Resolved
Thanks for your patience - we've restored service to our website. If you are still experiencing access issues, please try logging in at https://my.waveapps.com/login.
Posted Apr 09, 2020 - 17:03 EDT
Monitoring
Our website is now back up and we are actively monitoring.
Posted Apr 09, 2020 - 15:15 EDT
Update
We are still investigating the issue and working hard to restore service.
Posted Apr 09, 2020 - 13:01 EDT
Identified
Many users are seeing 404 errors when they try to access our website. We are investigating the issue. Further updates to follow.
Posted Apr 09, 2020 - 12:01 EDT