Payroll direct deposits are currently failing to process
Incident Report for Wave
Resolved
This incident has been resolved.
Posted Oct 19, 2021 - 19:38 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 19, 2021 - 18:24 EDT
Update
We're still currently investigating the issue, more details to come regarding a solution shortly.
Posted Oct 19, 2021 - 17:22 EDT
Investigating
We are currently investigating this issue.
Posted Oct 19, 2021 - 15:19 EDT
This incident affected: Payroll.