Investigating reports of login errors
Incident Report for Wave
Resolved
The issue that was impacting some customers' ability to complete certain actions in Wave (including accessing their Wave account or payroll product) is now resolved. Thank you for your patience.
Posted Dec 13, 2021 - 19:31 EST
Investigating
We are investigating reports that some customers are unable to access their Wave accounts. Further updates to follow.
Posted Dec 13, 2021 - 19:12 EST
This incident affected: Web Application, Accounting, Invoicing, Payments, Payroll, and Wave Money.