Reported errors in Wave

Incident Report for Wave

Resolved

This incident has been resolved. We apologize for any inconvenience accessing Wave during this time.
Posted Oct 27, 2025 - 10:47 EDT

Investigating

We are currently investigating reported errors within Wave when accessing various pages. We apologize for any inconvenience and further updates will follow.
Posted Oct 27, 2025 - 10:04 EDT
This incident affected: Accounting, Invoicing, and Payroll.