Investigating reports of invoices and estimate emails not sending to recipients

Incident Report for Wave

Resolved

Issues with invoice and estimate emails not being sent to recipients has been resolved. We apologize for the inconvenience during this time.
Posted Mar 12, 2026 - 13:51 EDT

Investigating

We are investigating reports that invoices and estimate emails are not sending to recipients. Further updates to follow.
Posted Mar 12, 2026 - 13:23 EDT
This incident affected: Invoicing.