Investigating reports of log in errors
Incident Report for
Wave
Resolved
Issues with logging into Wave have been resolved. We apologize for any inconvenience.
Posted
Sep
30
,
2025
-
04:13
EDT
Investigating
We are investigating reports of log in errors. Further updates to follow.
Posted
Sep
30
,
2025
-
03:37
EDT
This incident affected: Web Application.
×
Subscribe to Incident
Subscribe to updates for
Investigating reports of log in errors
via . You'll receive .