Wave public site is currently unavailable
Incident Report for Wave
Resolved
This incident has been resolved. Thank you for your patience
Posted Aug 23, 2021 - 18:25 UTC
Investigating
We are currently investigating reports that our public site is unable to be reached. Our engineering team is on the case and we hope to have a resolution ASAP. Please stay tuned for updates and thank you for your patience
Posted Aug 23, 2021 - 18:06 UTC
This incident affected: Web Application, Accounting, Invoicing, Payments, Payroll, and Wave Money.