We have identified and resolved an issue that was causing delays in recurring invoices being generated and automatic payments being charged.
Delayed recurring invoices have now been generated and any automatic payments associated with those recurring invoices applied to the saved payment methods.
Posted Apr 29, 2026 - 17:47 EDT
Monitoring
We have identified and resolved an issue that was causing delays in recurring invoices being generated and automatic payments being charged.
Delayed recurring invoices have now been generated and any automatic payments associated with those recurring invoices applied to the saved payment methods.
Posted Apr 29, 2026 - 15:35 EDT
Investigating
We have identified and are investigating an issue causing scheduled recurring invoices to not be generated. Automatic recurring charges that happen through those recurring invoices are also impacted due to this.
Creating and sending individual invoices, as well as payments against individual invoices are not affected at this time.
We thank you for your patience and we will share updates on next steps as they become available.