Slow loading speeds

Incident Report for Wave

Resolved

This incident has been resolved.
Posted Jun 23, 2025 - 10:54 EDT

Investigating

We're experiencing an elevated level of errors across Wave that can cause slowing loading speeds and some pages erroring out due to latency issues. We are investigating.
Posted Jun 23, 2025 - 10:26 EDT
This incident affected: Web Application, Accounting, Invoicing, Payments, Payroll, and Receipts Processing.