We're experiencing temporary issues with our Wave Payments setup.
Incident Report for Wave
Resolved
This incident has been resolved. Users should no longer experience any issues while setting up their Wave Payments account.
Posted May 15, 2020 - 12:49 UTC
Investigating
We are currently investigating this issue.
Posted May 15, 2020 - 01:41 UTC
This incident affected: Payments.