Investigating reports of issues with site usability

Incident Report for Wave

Resolved

The incident related to an issue with website usability has been resolved. Users should refresh their browser to resume normal application use.
Posted Apr 22, 2022 - 13:20 EDT

Monitoring

We've identified an issue that was interrupting website usability, and have implemented a fix. We are currently monitoring the results.
Posted Apr 22, 2022 - 13:10 EDT

Investigating

We are investigating reports that users are having issues with using our website. Further updates to follow.
Posted Apr 22, 2022 - 12:50 EDT
This incident affected: Web Application.