General website maintenance to be performed.
Scheduled for Oct 22, 03:00 - 03:30 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Oct 08, 2021 - 17:59 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Oct 08, 2021 - 17:56 UTC
Scheduled
Wave will be performing scheduled maintenance between 11:00 PM - 11:30 PM Eastern on October 21st, 2021. Your account and the Wave website will be unavailable during maintenance. We expect this to take about 10 minutes. Check this page for updates as maintenance progresses. Thank you for your patience while we upgrade our services!
Posted Oct 08, 2021 - 15:58 UTC
This scheduled maintenance affects: Web Application, Accounting, Invoicing, Payments, Payroll, and Wave Money.