US Payroll Billing Error

Incident Report for Wave

Update

We have reached out to the impacted customers to set expectations on next steps and the re-charging process. We are also working to ensure this error does not reappear in the future.
Posted Jan 07, 2026 - 16:32 EST

Identified

We have identified an issue related to payroll billing for some of our US payroll customers, meaning that their December 1st and/or January 1st bills did not charge as expected, despite the invoices being marked as 'paid'. We are looking into a resolution to re-attempt those charges. Thank you for your patience.
Posted Jan 07, 2026 - 09:43 EST
This incident affects: Payroll.