Investigating reports of Instant Payouts failing

Incident Report for Wave

Resolved

As of 1:41pm, instant payouts are processing normally.
Posted Mar 28, 2022 - 14:03 EDT

Update

We are continuing to investigate this issue.
Posted Mar 28, 2022 - 14:03 EDT

Investigating

We are investigating reports of Instant Payouts failing for the majority of our customers who have processed an Instant Payout since 11:50am. Further updates to follow.
Posted Mar 28, 2022 - 13:46 EDT
This incident affected: Payments.