Business Toggle (Top Right Corner of Wave) Missing

Incident Report for Wave

Resolved

This incident has been resolved, and the top bar of Wave (including the business switcher toggle and settings access) is appearing again. Please refresh your browser to see the fix in your account. We apologize for the interruption today.
Posted Mar 24, 2025 - 10:44 EDT

Investigating

We are currently investigating an issue blocking users from switching businesses or accessing their Settings page as expected. More information will come as we discover more. Thanks for your patience.
Posted Mar 24, 2025 - 10:28 EDT
This incident affected: Web Application.