We have identified an issue leading to overstated dollar amounts on some 2025 1099-NEC forms. Forms have been filed timely in light of the January 31st filing deadline, and Wave is actively working through corrections where needed.
Posted Jan 30, 2026 - 18:04 EST
Update
We are continuing to investigate the reported issue regarding the dollar amounts on 2025 1099-NEC forms for some Wave Payroll customers. Thank you for your ongoing patience.
Posted Jan 30, 2026 - 14:52 EST
Investigating
We are currently investigating a reported issue regarding the dollar amounts on 2025 1099-NEC forms for some Wave Payroll customers.