Report Accuracy Investigation
Incident Report for Wave
Resolved
The Reports issue has been resolved. We apologize for the interruption here - thanks for your patience, and have a good night.
Posted Mar 04, 2023 - 00:09 EST
Investigating
We are currently investigating an issue affecting the accuracy of Wave Reports for users. Thank you for your patience.
Posted Mar 03, 2023 - 23:56 EST
This incident affected: Accounting.