We're currently experiencing some issues loading data on the Payments page. Your account may be affected by this.
Incident Report for Wave
Resolved
This incident has been resolved. Payment processing was not impacted.
Posted May 14, 2020 - 21:39 UTC
Update
We are continuing to investigate this issue.
Posted May 14, 2020 - 20:54 UTC
Investigating
We are currently investigating this issue.
Posted May 14, 2020 - 20:25 UTC
This incident affected: Invoicing.