The issue has been resolved. We apologize for the interruption.
Posted Jun 23, 2026 - 15:20 EDT
Monitoring
A fix has been implemented for the timesheets issue, and we are monitoring.
Posted Jun 23, 2026 - 14:59 EDT
Investigating
We are investigating an issue that is blocking some users from saving their timesheets for payroll. Users are encouraged to troubleshoot their browsers to see if this resolves the issue. We will share updates as they become available.