A fix has been implemented and we are monitoring the results.
Posted Sep 03, 2024 - 17:00 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 03, 2024 - 16:22 EDT
Investigating
We are investigating reports that customers are unable to access Wave through the mobile app. Further updates to follow. In the meantime, web browser logins are working successfully.