Working through larger support volumes

Incident Report for Wave

Update

We are currently working through a larger volume of payroll support requests. While we are working on answering those, we have also created this guide to assist you with some issues you might experience in the meantime: https://support.waveapps.com/hc/en-us/articles/39407501814036-Payroll-troubleshooting-guide We appreciate your patience.
Posted Jul 22, 2025 - 15:19 EDT

Update

We are currently working through a larger volume of support requests regarding payroll issues, and we are resolving these issues at the earliest opportunity. As a result, chat hours may be reduced in the coming week so we can get back to our customers. We appreciate your patience.
Posted Jun 19, 2025 - 20:21 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 19, 2025 - 20:20 EDT

Identified

We are currently working through a larger volume of support requests regarding payroll issues, and we are resolving these issues at the earliest opportunity. As a result, chat hours may be reduced in the coming week so we can get back to our customers. We appreciate your patience.
Posted Jun 19, 2025 - 17:06 EDT
This incident affects: Payroll.