US customers unable to change the card associated with their instant payouts
Incident Report for Wave
Resolved
We have resolved the issue preventing US customers from updating their instant payout cards. If you are still unable to update your card please reach out to us through your account.
Posted Oct 22, 2021 - 10:05 EDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 21, 2021 - 23:24 EDT
Update
We are working with our partners to resolve the issue preventing US customers from saving a new card for their instant payouts. Payouts themselves remain unaffected. We will provide further updates as they become available.
Posted Oct 21, 2021 - 11:03 EDT
Identified
We have identified an issues preventing US customers from changing the card associated with their instant payouts. Payouts themselves are unaffected. We are continuing to work to resolve this and will provide further updates as they become available.
Posted Oct 20, 2021 - 17:11 EDT
This incident affected: Payments.