Recurring Invoices - Creating and saving
Incident Report for Wave
Resolved
We have identified and resolved the issue affecting user's ability to create or save recurring invoices. If the issue still persists, then you may need to clear your browser cache. Thank you for your patience during this time.
Posted Feb 09, 2023 - 13:34 EST
Investigating
We are currently investigating an issue where some users are unable to create or save new Recurring Invoices. Our team are aware of the issue and are looking in to the cause of this issue.
Posted Feb 09, 2023 - 13:14 EST
This incident affected: Invoicing.