We're currently experiencing authorization declines with some transactions using the Wave Money banking card

Incident Report for Wave

Resolved

This incident has been resolved.
Posted Oct 18, 2021 - 08:32 EDT

Investigating

We are currently investigating this issue.
Posted Oct 16, 2021 - 16:58 EDT