Wave Payments Activation
Incident Report for Wave
Resolved
The issue affecting Wave Payments account activations and deposit account updates has been resolved. We apologize for the interruption, and thank you for your patience.
Posted Aug 09, 2021 - 19:10 EDT
Update
We are continuing to work on resolving the issue affecting the ability to add Wave Payments to your account. This issue also affects the ability to update your Wave Payments deposits account.

We will provide updates as they become available - thanks for your patience.
Posted Aug 09, 2021 - 18:51 EDT
Update
We are continuing to work on resolving the issue affecting the ability to add Wave Payments to your account. This issue also affects the ability to update your Wave Payments deposits account.

We will provide updates as they become available - thanks for your patience.
Posted Aug 09, 2021 - 16:48 EDT
Identified
We have identified the root issue affecting the ability to add Wave Payments to your account, and we are working towards a resolution. Existing payments customers and their payments processing remain unaffected, and we will continue to provide updates as they become available.
Posted Aug 09, 2021 - 16:05 EDT
Update
We are continuing to investigate the issue that is affecting the ability to turn on Wave Payments.
Posted Aug 09, 2021 - 15:48 EDT
Investigating
We are currently investigating an issue that is affecting the ability to turn on Wave Payments. We will post updates as they become available.
Posted Aug 09, 2021 - 15:14 EDT
This incident affected: Payments.