Issues Accessing Purchases pages and Uploading Bank Statements
Incident Report for Wave
Resolved
This incident has been resolved.
Posted Sep 26, 2024 - 14:06 EDT
Investigating
We are investigating reports that users unable to access the Bills, Vendors, Products & Services, Classic Estimates, and Statement Upload pages. Further updates to follow.
Posted Sep 26, 2024 - 12:04 EDT
This incident affected: Accounting.