Wave's public site is currently unavailable
Incident Report for Wave
Resolved
Our engineering team have identified and resolved the issue. Our public site is now back up and running. Thanks for your patience!
Posted Jun 16, 2020 - 16:08 EDT
Investigating
We are currently investigating reports that our public site is unable to be reached. Our Accounting and Invoicing platform are operating as expected. We will provide further updates as they come in.
Posted Jun 16, 2020 - 15:10 EDT