Slow loading pages
Incident Report for
Wave
Resolved
This incident has been resolved. Thank you for your patience.
Posted
Apr
17
,
2024
-
10:07
EDT
Identified
The issue has been identified and we're implementing a fix.
Posted
Apr
17
,
2024
-
09:58
EDT
Investigating
We are currently investigating an issue with error pages and slow loading pages on Wave.
Posted
Apr
17
,
2024
-
09:50
EDT
This incident affected: Web Application, Accounting, Invoicing, Payments, Payroll, and Receipts Processing.
×
Subscribe to Incident
Subscribe to updates for
Slow loading pages
via . You'll receive .