Wave Payment transactions not processing
Incident Report for Wave
Resolved
The incident affecting payments being processed has now been resolved. Payments processed through Wave will now be functioning as usual.
Posted May 11, 2023 - 05:39 EDT
Investigating
We are currently investigating an issue with a third party affecting the ability to process payments through Wave. This is affecting credit card, bank payments and instant payouts.
Posted May 11, 2023 - 04:03 EDT
This incident affected: Payments.