Increased Errors on Invoicing Features

Incident Report for Wave

Resolved

This incident has been resolved. Thank you for your patience and we apologize for the interruption today.
Posted Apr 20, 2026 - 14:31 EDT

Investigating

We are currently investigating an issue leading to increased errors on invoicing-related pages in Wave, for some Wave users and/or their clients.
Posted Apr 20, 2026 - 13:16 EDT
This incident affected: Invoicing.