Issue is now resolved. We thank you for your patience.
Posted Apr 09, 2026 - 13:07 EDT
Update
We are continuing to monitor for any further issues.
Posted Apr 09, 2026 - 13:06 EDT
Monitoring
Wave is currently impacted by an incident occurring with our Payroll partner. Payroll users might find that taking Payroll related actions is delayed or some pages are not loading. Our partner has released a fix and we are monitoring. Further updates will be posted as new information becomes available.