We're experiencing an issue of some users not being able to access their Dashboard
Incident Report for Wave
Resolved
This incident has been resolved. If you are still unable to fully load the dashboard, please refresh your browser.
Posted Mar 22, 2023 - 15:42 EDT
Investigating
We're currently investigating an issue that's preventing some users from being able to access the Dashboard page in the web version of Wave. More details to come as we know more.
Posted Mar 22, 2023 - 15:31 EDT
This incident affected: Web Application.