Issues using some parts of Wave
Incident Report for
Wave
Resolved
This incident has now been resolved. Thank you for your patience during this time.
Posted
Apr
11
,
2024
-
12:27
EDT
Investigating
We are currently investigating an issue with customer's ability to purchase or use some Pro Plan features at this time.
Posted
Apr
11
,
2024
-
12:25
EDT
This incident affected: Web Application.
×
Subscribe to Incident
Subscribe to updates for
Issues using some parts of Wave
via . You'll receive .