Wave Impacted by 3rd party incident
Incident Report for Wave
Resolved
We have reached out to users impacted by yesterday morning's payments outage. Thank you for your patience and we apologize for the interruption to your workflow.
Posted Nov 15, 2023 - 17:37 EST
Update
We are continuing to monitor for any further issues.
Posted Nov 14, 2023 - 09:39 EST
Update
New online payments on invoices and checkouts are now processing as expected. We are investigating the impact on any affected payments from the incident window, and will post further information as it becomes available.
Posted Nov 14, 2023 - 09:36 EST
Monitoring
Wave is currently impacted by an incident occurring with one of our 3rd party partners. Online payments on invoices and checkouts may not process successfully. Further updates will be posted as new information becomes available.
Posted Nov 14, 2023 - 09:05 EST
This incident affected: Payments.