Increased errors in Wave
Incident Report for Wave
Resolved
The incident has been resolved, and users should be able to access Wave as expected. We are sorry for the interruption today.
Posted Jan 31, 2024 - 14:39 EST
Investigating
We are currently investigating reports of heightened errors and slow loading times across Wave. More details will be shared once available.
Posted Jan 31, 2024 - 14:24 EST
This incident affected: Web Application, Accounting, Invoicing, Payments, Payroll, and Receipts Processing.