Loading issues during Credit Card Payment Processing via Wave generated Invoices and Payment Links

Incident Report for Wave

Resolved

This incident has been resolved.
Posted Apr 14, 2026 - 17:01 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 14, 2026 - 16:36 EDT

Identified

Some clients of Wave Payment users are unable to input their Credit Card details for Payment processing through Wave generated Invoices and Payment Links. We are looking into this.
Posted Apr 14, 2026 - 16:25 EDT
This incident affected: Payments.