Reports of Slow Loading and Error Messages in Wave

Incident Report for Wave

Resolved

This issue has been resolved. Thanks for your patience and we're sorry about the interruption today.
Posted May 03, 2023 - 11:03 EDT

Investigating

We are investigating reports of slow loading times and error messages throughout Wave.
Posted May 03, 2023 - 10:55 EDT
This incident affected: Web Application.