Short Payout Delay for American Customers
Incident Report for Wave
Resolved
The issue has been resolved, and the July 8th payouts will deliver to customers this afternoon. Thank you for your patience in this matter.
Posted Jul 08, 2024 - 14:03 EDT
Investigating
We are monitoring a short delay in payout delivery for some of our American customers. Payouts for July 8th can be expected to arrive this afternoon rather than this morning.
Posted Jul 08, 2024 - 05:55 EDT
This incident affected: Payments.