We're currently experiencing some service degradation. This may affect some links or pages while trying to navigate our software.
Incident Report for Wave
Resolved
This incident has been resolved.
Posted Apr 19, 2021 - 15:16 UTC
Update
We are continuing to investigate this issue.
Posted Apr 19, 2021 - 15:15 UTC
Investigating
We are currently investigating this issue.
Posted Apr 19, 2021 - 14:35 UTC
This incident affected: Web Application, Accounting, Invoicing, Payments, Payroll, and Wave Money.