We're currently experiencing some service degradation. This may affect some links or pages while trying to navigate our software.
Incident Report for Wave
Resolved
This incident has been resolved. Our service degradation is now clear and website is functioning as expected.
Posted May 15, 2020 - 01:05 UTC
Investigating
We are currently investigating this issue.
Posted May 15, 2020 - 00:15 UTC
This incident affected: Web Application.