Delayed May 2nd Payouts for USA Wave Payments Customers
Incident Report for Wave
Resolved
We have found a resolution around the issue delaying May 2nd payouts for USA Wave Payments customers. These payouts should land today, but will be at a delayed time. We expect payouts to land in bank accounts sometime this evening. We will continue to monitor the situation as payouts begin to land later today. Thank you for your patience during this time.
Posted May 02, 2023 - 12:58 EDT
Update
We are continuing to investigate the issue delaying May 2nd payouts for USA Wave Payments customers. We are looking to resolve this as soon as possible. Thanks for your ongoing patience.
Posted May 02, 2023 - 10:43 EDT
Investigating
We are investigating reports that USA Wave Payments customers are experiencing a delay receiving payouts scheduled for May 2nd. We are looking to resolve this as soon as possible.
Posted May 02, 2023 - 09:30 EDT
This incident affected: Payments.