Issue with Wave Payments application
Incident Report for Wave
Resolved
This issue is now resolved. Users should now be able to complete the Wave Payments applications as normal.
Posted Mar 09, 2022 - 18:05 EST
Monitoring
A fix has been implemented to and we are currently monitoring the situation.
Posted Mar 09, 2022 - 13:19 EST
Investigating
Users attempted to complete the Wave Payments application may see their application get stuck at the final stage. The team are investigating this now and more updates are to follow.
Posted Mar 09, 2022 - 11:44 EST
This incident affected: Payments.