Public site is down
Incident Report for Wave
Resolved
Incident has been resolved. Wave site is fully functioning again.
Posted Jul 17, 2020 - 18:16 EDT
Investigating
We are currently investigating reports that our public site is unable to be reached. We believe that this is related to ongoing issue that Cloudflare is experiencing. Stay tuned for updates.
Posted Jul 17, 2020 - 17:36 EDT
This incident affected: Web Application, Accounting, Invoicing, Payments, and Payroll.