Investigating reports of business logos not appearing on invoice or estimate emails and exported PDF's

Incident Report for Wave

Resolved

This incident has been resolved.
Posted Jul 29, 2026 - 16:20 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 29, 2026 - 16:06 EDT

Investigating

We are investigating reports that emailed invoices and estimates are not including the business logo on the attached PDF. The business logo is also not included on invoices or emails that are exported as PDF's. Further updates to follow.
Posted Jul 29, 2026 - 15:43 EDT
This incident affected: Invoicing.