Delays to recurring invoices
Incident Report for Wave
Resolved
This incident has now been fully resolved and any impact to invoicing has been addressed. Thank you for your patience.
Posted Sep 01, 2022 - 14:00 EDT
Monitoring
The issue which was delaying recurring invoices has been resolved and we are monitoring recovery. Please allow time for your waiting invoices to be sent out and thank you for your patience.
Posted Sep 01, 2022 - 12:51 EDT
Update
The issue impacting working with and paying invoices has been resolved but we continue to investigate ongoing delays to recurring invoices. At this time, creating and sending individual invoices, as well as other Wave account functions are not impacted. Further updates will be posted as they become available.
Posted Sep 01, 2022 - 11:36 EDT
Update
We are continuing to investigate an issue impacting invoices within Wave. As we work to resolve the delays users working with invoices or customers attempting to pay them may experience slowness or timeouts. At this time other Wave account functions are not affected and further updates will be posted as they become available.
Posted Sep 01, 2022 - 11:14 EDT
Identified
We have identified and are investigating an issue causing delays to recurring invoices being sent by Wave. Please note that creating and sending individual invoices, as well as other Wave account functions are not affected. Further updates will be posted as they become available.
Posted Sep 01, 2022 - 10:44 EDT
This incident affected: Invoicing.