Wave is currently down for some users (specifically on the west coast of the US)

Incident Report for Wave

Resolved

The issue affecting some Wave users' ability to access the site has been resolved. Users should now be able to access their accounts as expected. Thanks for your patience and we're sorry for the interruption.
Posted Feb 15, 2022 - 18:27 EST

Investigating

We are currently investigating this issue.
Posted Feb 15, 2022 - 18:04 EST
This incident affected: Web Application, Accounting, Invoicing, Payments, and Payroll.