Investigating reports of login errors
Incident Report for Wave
Resolved
This incident has now been resolved and Wave accounts should now be fully accessible. Thank you for your patience!
Posted May 07, 2021 - 16:27 UTC
Update
We are continuing to investigate this issue.
Posted May 07, 2021 - 16:10 UTC
Investigating
We are investigating reports that customers are unable to access Wave. Further updates to follow.
Posted May 07, 2021 - 16:10 UTC
This incident affected: Web Application, Accounting, Invoicing, Payments, Payroll, and Wave Money.