Reports out-of-sync for some businesses

Incident Report for Wave

Resolved

This incident has been resolved. We apologize for the interruption today.
Posted Dec 02, 2025 - 19:50 EST

Identified

We have identified an issue that is causing inaccurate reports for some business owners in Wave. We are working on a solution and apologize for the technical interruption.
Posted Dec 02, 2025 - 15:37 EST
This incident affected: Accounting.