We're currently experiencing an error when attempting to send out invoices
Incident Report for Wave
Resolved
This incident has been resolved.
Posted Sep 16, 2021 - 16:31 UTC
Investigating
Our team is actively investigating the error message being received when attempting to send out an invoice. Please note that the rest of your Wave account should be functioning as expected.
Posted Sep 16, 2021 - 16:26 UTC
This incident affected: Invoicing.