Site-wide error messages
Incident Report for Wave
Resolved
The incident affecting users accessing Wave has now been resolved. Thank you for your patience during this time.
Posted May 11, 2023 - 12:43 EDT
Investigating
We are currently investigating issues within Wave causing users to receive error messages when loading pages. As soon as we have more information we will update here.
Posted May 11, 2023 - 12:15 EDT
This incident affected: Web Application, Accounting, and Invoicing.